Jump to content

DONT STAY LURKING AS A GUEST,

JOIN TEF AND BENEFIT FROM MEMBERSHIP:

CLICK HERE TO JOIN.

Recommended Posts

hazey11

Hi can someone offer me some advice please. I have a small hyco inline heater and tap serving my kitchen sink. Recently there has been a sweet spot on the tap that i have needed to find to get the heater started. Now i need to jiggle it round loads to get the heater started. (I can tell when it comes on as the lights flick). Is this likely to be a tap problem or a heater problem? Should i try changing the tap or get a plumber around?

 

i have tried turning the cold feed to the tap off and this didn't improve anything.

 

heater looks like this : https://goo.gl/images/vhX9Vm 

 

 

Thanks for any advice, 

Alex

Share this post


Link to post
Share on other sites
Ardet R

It sounds like the flow switch internal to the heater is not operating correctly, presumably blocked with scale or gunge.

I would suggest that a plumber may be able to clear the blockage, from a non plumbers point of view!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of UseWe have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.