Jump to content
Kyle maylor

Hi everybody, I have an issue with my dash

Recommended Posts

Kyle maylor

Not sure how to add a picture for you guys but I have a 2013 trafic, it often from start or just randomly when I’m driving the small square screen that shows the fuel time and mileage will scramble to just all orange lights like a glitch, it corrects itself but then will do it again, when it dies this I can see the outline off all the fault icons etc, maybe a loose plug connection?? 
 

many help greatly appreciated 

Share this post


Link to post
Share on other sites
Geoff1946

Can you associate the event with anything?  e.g. hitting a bump, braking, heater or air-con switching?  

Years ago, when vehicles had analogue gauges and a couple of lamps on the dash weird faults were usually due to broken or poor earth wires, either between the dash and vehicle body or between engine and vehicle body. Could be an equally likely source of issues with modern electronic dash but there are now also a million other possibilities. 

For instance a transit minibus I used to be involved with suffered failing flexible printed circuit sections within the cluster which caused intermittent  problems.  Such endemic problems are usually known to the auto electrics trade if you enquire. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of UseWe have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.